Issue#1662: VS2015 error with Unity

  • During debug in VS2015 (solution=x86 ) I get a window popup to find file "BaseClassBindings.gen.cs" What is this?? What do I do? Has anyone seen something like this before??

    0 Answers

    Sorry, your answer is too short !

  • Issue#2889: Unity - Build Error on AssembleConverter.exe in VS2015

    I am using Visual Studio 2015 Update 1 along with Unity 5.3.1p4 to build a Universal Windows App. I'm also using SDK 10.0.10586.15 When building in VS using Debug, Release, or Master with x86 or x64 I recieve the following output: 1>------ Build started: Project: Skyhook, Configuration: Release x86 ------ 1> UnityInstallationDir "C:\Program Files\Unity_5_3_1\Editor". 1> UnityWSAPlayerDir "C:\Program Files\Unity_5_3_1\Editor\Data\PlaybackEngines\MetroSupport". 1> UnityProjectDir... Build Error on AssembleConverter.exe in VS2015

  • Issue#47844: Unity - App in debug mode error, keystore set, still issue

    I'm a Unity developer but today I was going to publish my first app to the Google Playstore. My app runs fine on the testing device, I have set the keystore and not checked 'developement' withing the publish settings. However, every time I try to publish it and upload the app to the playstore, I get the error: 'App is in debug mode'. I've searched hours to find this issue, updated my JDK, Android SDK and such, but nothing changes. I'm using Unity3D 5.3.0f4. Does anyone has an idea what I'm... App in debug mode error, keystore set, still issue

  • Issue#287729: Unity - 5.3.4f1 Issue: All compilers error have to be fixed before you can enter play mode

    I just upgraded to 5.3.4, and I am getting the usual "All compiler error" message, even though I don't have any compiler error, as far as I can see. I do get 2 error everytime I open the scene. Relating to UNetWeaver, which will go if I click on "Clear" on the output window. Once I "Clear" the output window, I don't have anymore errors. But I still get the "All compiler error.." message, and cannot play the game in the editor. My last upgrade was 5.0.2. Already tried to reimport... 5.3.4f1 Issue: All compilers error have to be fixed before you can enter play mode

  • Issue#295990: Unity - 5.4.0B10 - Native Plugin Issue - .bundle broken and error with .dll (regression)

    In both 5.4.0B9 and the latest 5.4.0B10, .bundle files are no longer recognized. There is also an error thrown now when inspecting a .dll file. GetEditorTargetName is not allowed to be called from a MonoBehaviour constructor, call it in Awake or Start instead. Called from script 'PluginImporterInspector' on game object ''. See "Script Serialization" page in the Unity Manual for further details. UnityEditor.PluginImporterInspector:.ctor()Click to expand... The bug report was filed under case... 5.4.0B10 - Native Plugin Issue - .bundle broken and error with .dll (regression)

  • Issue#422862: Unity - Editor issue ? Error message when calling EditorWindow.Close in EditorWindow.OnLostFocus

    Hi I'm trying to close an EditorWindow from its OnLostFocus method. I'm getting that error message in the log : Unable to remove Pane - it's not IN the window UnityEditor.EditorWindow:Close() LocalizationTextIDPicker:OnLostFocus() (at Assets/Framework/Editor/LocalizeTextInspector.cs:231) UnityEditor.HostView:OnLostFocus()​ I can't see what's wrong. Looking at the code I see no reason for that message to show up. Should I report that as an issue ?

  • Issue#632366: Unity - Error opening shader (issue 733702)

    Issue 733702 is marked as fixed in 5.4, however in beta 17 I'm still getting it. Is the fix not in the beta yet? https://issuetracker.unity3d.com/is...it-in-visual-studio-opens-monodevelop-instead The other thing I see which appears to be related is that VS throws this error (VS2013 Pro): View attachment 184489

  • Issue#813050: Unity - Build Error when I am building the Game for windows Phone, Please help me solve this issue

    Error building Player: Exception: Error: method `System.Boolean System.Threading.WaitHandle::WaitOne(System.Int32,System.Boolean)` doesn't exist in target framework. It is referenced from Assembly-CSharp.dll at System.Void MegaModifiers:oWork(System.Object). Error: method `System.String System.Environment::GetEnvironmentVariable(System.String)` doesn't exist in target framework. It is referenced from Assembly-CSharp.dll at System.Void MegaGrab:oGrabTGA(). Error: method `System.String... Build Error when I am building the Game for windows Phone, Please help me solve this issue

  • Issue#862196: Unity - 5.3.5p6 error logging issue

    Hi, I've just updated to patch release 6 for 5.3.5 from patch release 1 for 5.3.5. I get this error log that looks like some sort of assert in the console thousands of times. tex->GetWidth() == width && tex->GetHeight() == height it (seems) to occur when the normalized view port rect and or orthographic size (on the camera, in debug inspector) has NaN values. Another note is that the camera is a secondary camera that draws ontop of a prior one, and it does not use a render texture. I do... 5.3.5p6 error logging issue

  • Issue#959743: Unity - Asset Store Download Error - Can't Resolve Host Issue...

    Trying to download new and updated assets from the asset store, but get the error: Can't Resolve Host. Unity 5.3.5f1 running on a Mac - behind a proxy. Added http_proxy and https_proxy environment variables for the proxy, but that didn't help. Tried an NSLookup for the address that's saying it can't resolve and it doesn't find it. The address in the error looks odd as well: Error: Couldn't resolve host 'assetstore.unity3d.com.s3.amazonaws.com' BTW - I don't have problems downloading... Asset Store Download Error - Can't Resolve Host Issue...

  • Issue#1437: Unity Android Plugin Error: java.lang.NoClassDefFoundError: Failed resolution of JAVA Class

    Hello everyone, I'm trying to build an Android plugin following the instructions here: http://www.thegamecontriver.com/2015/04/android-plugin-unity-android-studio.html I was able to compile and integrate my plugin in Unity, and everything works as expected. But now, I'm trying to add external libraries to my plugin (so far I've tried Facebook Android SDK, Google Analytics..) and when I try to use any of the classes stored in these libraries I'm getting the following errors:... Unity Android Plugin Error: java.lang.NoClassDefFoundError: Failed resolution of JAVA Class

  • Issue#1594: Unity - Google Cardboard signal 11 (SIGSEGV) error

    Hello, I use Google Cardboard SDK (0.6) in my Android application. But when I resume the Cardboard app, sometimes it crash. This is a Android Home Applcation. My app include <category android:name="android.intent.category.DEFAULT"/> <category android:name="android.intent.category.HOME"/> in AndroidManifest.xml So, when I click the home button, it crash. Here is my crash log. 01-24 11:37:44.984 907 907 F DEBUG : *** *** *** *** *** *** *** *** *** *** *** *** *** *** *** *** 01-24... Google Cardboard signal 11 (SIGSEGV) error

  • Issue#1715: Unity - 2D Level Menu Issue!

    Hello there devs! I am making a 2d game and i just created my level select menu but i seem to be facing a problem.When the player starts, level 1 is automatically unlocked and the player needs to finish it in order to get to level 2.So when level 1 is finished i set in playerprefs the ("UnlockedLevel") parameter to 2 and so on so that the next level unlocks.But, i just realized that if the player pressed on level 1 and then somehow he goes back to the levelmenu scene without finishing it,... 2D Level Menu Issue!

  • Issue#1750: Unity - Rendering error on cellphone

    Hi all, I am currently making a game targeting cellphones (Android, Windows Phone 8.1 and Windows 10 Universal). But it renders wrong on my cellphones, Windows 10 Universal (right but this is my pc, don't own a Windows 10 cellphone): ... Rendering error on cellphone

  • Issue#1793: Unity - Vertex/Fragment shader : issue with alpha blending

    Hi. I am having a hard time figuring out an issue I have with a simple alpha blending shader (I had the same kind of issue with alpha test). Here are a few pictures so you get the basic idea : View attachment 170683 View attachment 170684 By simply moving the camera back and force, my shader kind of switch between being displayed and not. These screens are from the Editor, but I have the same issue In Game. However, In Game, another issue comes up :... Vertex/Fragment shader : issue with alpha blending

  • Issue#1839: Unity - iTween issue

    Hi, I got error on the console about this line of code and don't understand how to solve it, anyone can help please ? iTween.ScaleTo(tailleDistance,iTween.Hash("x",15,"y",15,"z",15,"time",1.6,"easetype",iTween.EaseType.easeInOutCubic)); Regards,

  • Issue#2470: Unity - Random Editor issue..5.3.1.2 | seems VS 2016 is causing editor to turn all warnings into err

    It happens in all my projects, and it only happens after I open VS (double click on script), make a script change, hit save..I can fix 'one' of the errors(warnings), unity re compiles...and Editor comes back to normal..for awhile..then back to that behavior,,, This is blocking my development chi....(I could fix every single warning)... here is the thing..under 'preferences', attach to editor...I can not Turn that Off...EVER.... I unchecked it, restart unity...it is active again...(that is... Random Editor issue..5.3.1.2 | seems VS 2016 is causing editor to turn all warnings into errors..

  • Issue#2984: Unity - Voxel vs Shadows Error

    Hello Guys, So I am currently importing voxel mesh in .obj format created in Qubicle. I have shadows turned up to highest quality and noticed this fun little problem. Any ideas how to fix this? 90% of the game's content will be voxel based.

  • Issue#3038: Unity - Object counter issue: not working

    I am trying to make a script that counts objects in a list that are already active, I want my activeAmount to increase by 1 whenever a gameobject in the array is set to false, however I seem unable to. So far it either increases by 1 and then doesn't change, or it continuously increases without stop, any help is appreciated. I couldn't find any other question posted that dealt with this. Code (CSharp):  using UnityEngine; using UnityEngine.UI; using System.Collections; using... Object counter issue: not working

  • Issue#3810: Unity - WWW Load movie FMOD error

    Hi there, Since 5.3 (and latest 5.3.1 too) : Trying to load an .ogg or .ogv video through the WWW Class (load movie) will throw this error : Error: Cannot create FMOD::Sound instance for resource (null) Nothing I can do to fix it, seems to be a 5.3 bug. Others are talking about same bug here : http://stackoverflow.com/questions/34364732/unable-to-load-movie-via-www Thank you !

  • Issue#3977: Unity - Unet server using Web Sockets has performance issue

    I am experiencing CPU usage issue when running Unet server (as Windows desktop build) with and without checked option "Use Web Sockets". It looks like the build is 20-30x slower with Web Sockets and profiler does not show nothing interesting. Do you experience same behaviour? Is it known issue?

  • Issue#3984: Can't upgrade project to Unity 5.3: Unity error

    Hi, I just tried to upgrade, waited for 2 hours for my project to upgrade untill the progress bar was almost to its end. Just to discover I get an error:"Error, do you want to debug the error in visual studio?", well I tried, but I had no idea what to do so I closed and tried again. Thankfully the progress bar started again about where it left but the same error. I opened another project which upgraded ok and now I tried it again. I get this error: "The Unity editor isn't working anymore".... Can't upgrade project to Unity 5.3: Unity error

  • Issue#4273: Unity - AudioSource.PlayClipAtPoint giving an error.

    I have this method in a script on a gameObject: Code (CSharp): public void PlayNewClip(string name, float volume){         for (int i = 0; i < ASources.Length; i++) {             if(ASources[i].clip.name == name){                 ASources[i].PlayClipAtPoint(ASources[i].clip,transform.position);                 break;             }         }     } But it gives me the following error: error CS0176: Static member `UnityEngine.AudioSource.PlayClipAtPoint(UnityEngine.AudioClip,... AudioSource.PlayClipAtPoint giving an error.

  • Issue#4278: Unity - Crash & Error reporting services

    As part of a research i'm doing to find a good crash/error reporting service, i'd like to ask if anyone used any of these services ? Please comment if you also recommend it or not, or any other feedback you may have

  • Issue#4346: [RESOLVED] Win10 UWP - Unity 5.2 System.Runtime issue

    Cannot build a Win10 UWP Unity 5.2 project in VS2015 (14.0.23107.0 D14REL). Cannot resolve Assembly or Windows Metadata file 'System.Runtime.dll' Here is what is included in the csproj file that gets created from Unity: <Reference Include="System.Runtime"> <HintPath>C:\Users\[MYLOGIN]\.nuget\packages\System.Runtime\4.0.20\ref\dotnet\System.Runtime.dll</HintPath> </Reference> The file exists at that location. In VS2015, in the Object Browser, I can see System.Runtime and the... [RESOLVED] Win10 UWP - Unity 5.2 System.Runtime issue

  • Issue#4896: Unity - Social Api issue

    Greetings! I have an issue with IOS Game Center. 1. Social.ReportProgress doesn't work. It calls !success everytime 2. GameCenterPlatform.ShowLeaderboardUi( id, tamescope) always shows all my leaderboards, but i need to open only specific board with its ID. 3. Localuser.LoadAchievements() always return empty IAchievement[] achievements with lenght == 0 All leaderboards and achievements are created in ITunes Connect and tested directly with xcode and with testflight with different users.... Social Api issue

  • Issue#5004: Android - Unknown issue with Google Play Services Error

    I am getting a "Unknown issue with Google Play Services Error" when i open Google Apps like Gmail. I recently Unlocked the Bootloader and Rooted my Turbo. I dont see Google Play Services in Play Store to Update. Does anyone have any suggestions for the issue? Thanks in advance.

  • Issue#5194: Android - [SOLVED] Unknown issue with Google Play Services Error

    I am getting a "Unknown issue with Google Play Services Error" when i open Google Apps like Gmail. I recently Unlocked the Bootloader and Rooted my Turbo. I dont see Google Play Services in Play Store to Update. Does anyone have any suggestions for the issue? Thanks in advance.

  • Issue#5343: Unity - Tree creator bark material issue

    I'm having an issue with the tree creator. When I select a bark material for a branch, the texture is clamped (see the image). The texture itself is 1024x1024 and is set to Wrap mode: Repeat. It works without this issue elsewhere. What am I missing? View attachment 100512

  • Issue#5448: Unity - Inconsistent Error in Firefox for running WebGL Builds

    I am attempting to make a build of this project: https://github.com/hecomi/Unity-WebGL-3D-Chat I am able to run other WebGL builds from local files that I created from other Unity projects. Other WebGL builds run in the same browser, (Firefox 41.0) , but when I try to run a build of the WebGL 3D Chat program, I get an error telling me to use another browser. It seems your browser does not support running Unity WebGL content from file:// urls. Please upload it to an http...Click to expand... Inconsistent Error in Firefox for running WebGL Builds