Issue#2279: Linux - MySQL workbench with MariaDB

  • [Linux Mint]

    [email protected] ~ $ sudo apt-get install mysql-workbench
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:

    The following packages have unmet dependencies:
    mysql-workbench : Depends: mysql-client
    E: Unable to correct problems, you have held broken packages.

    Above is what I get when I try to install MySQL workbench with me MariaDB database server. I went to the MySQL website and tried to download the .deb file directly but this is what I got when I tried to run the file. -> Error: Dependence is not satisfiable: libatkmm-1.6-1v5 (>= 2.22.1)

    Any ideas on how I can fix this? Or is it even possible to install MySQL workbench with MariaDB? Thanks.

    0 Answers

    Sorry, your answer is too short !

  • Issue#134609: Linux - MySQL/MariaDB Upper Casing letters/names in fields

    Had a problem with a database (surprise!), that contained names. Names were entered by a variety of persons/programs, so we got a lump of stuff like: DAVID david j. wilson Franklin ...along with last names like: VAN HORN Johnson wilson None of which looked too good when it came time to print things out for them. While there is an easy method of plain upper-casing things, for things like "j. wilson" it didn't work right. It would upper-case the J, but not the W in "Wilson", same for last names. Bang this in to your DB console: Code: DELIMITER ||  CREATE FUNCTION `UC_Words`( str VARCHAR(255) ) RETURNS VARCHAR(255) BEGIN    DECLARE c CHAR(1);    DECLARE s VARCHAR(255);    DECLARE i INT DEFAULT 1;    DECLARE bool INT DEFAULT 1;    DECLARE punct CHAR(17) DEFAULT ' ()[]{},.-_!@;:?/';    SET s = LCASE( str );    WHILE i < LENGTH( str ) DO      BEGIN   

  • Issue#184002: Linux - Moving from MySQL to Postgresql; Encoding issue

    Hi all, I have this MySQL database, and for unknown reasons it was created with LATIN1 encoding. However, the standards dictate UTF-8 encoding; Now for many reasons, we want to move away from MySQL towards PostgreSQL (9.4 and later); The thing is, one of the tables uses special characters (like country names with special glyphs in it (take for example how Curacao actually spells (with the c-cedille)). I tried various ways to convert the LATIN1 encoding used to UTF-8, but so far, the data comes out garbled. The databases run on the same host, which runs Linux (RHEL6). What I tried: - dumping the data, convert with iconv - dumping the data with a PHP script, convert on the fly with iconv() - dumping the data with the same PHP script and convert on the fly with mb_convert_encoding() As a test, I created a PostgreSQL database with LATIN1 encoding and dump the data there; The data compares well, it looks the same... However, I don't know how to copy the data from one database to anot

  • Issue#232817: Linux - current, akonadi, mariadb, mysql and kmail

    System: Slackware64-current, up to date. I switched from using kmail to thunderbird a couple of months ago, but now need to access an old email still stored on kmail. When I try and open kmail I get the "Akonadi control process not registered at D-bus", "Akonadi server process not registered at D-bus" and "No resource agents found". I seem to recall this being an issue a while ago, but thought it had been sorted. Is there something in recent updates that has caused it to re-appear? Most importantly, does anyone know what the fix is? I need to get at that old email.....! Cheers, -- Pete

  • Issue#558442: Linux - LXer: Ubuntu 16.04 LAMP server tutorial with Apache 2.4, PHP 7 and MariaDB (instead of MySQL

    Published at LXer: LAMP is short for Linux, Apache, MySQL, PHP. This tutorial shows how you can install an Apache 2.4 web server on an Ubuntu 16.04 (Xenial Xerus) server with PHP 7 support (mod_php) and MySQL / MariaDB. Additionally, I will install PHPMyAdmin to make MySQL administration easier. A LAMP setup is the perfect basis for CMS systems like Joomla, Wordpress or Drupal. Read More...

  • Issue#971108: Linux - MariaDB/MySQL broken on fresh installation

    As usual I am trying to initialize MariaDB/MySQL on 14.2. Unfortunately can't run secure installation: Code: # mysql_install_db Installing MariaDB/MySQL system tables in '/var/lib/mysql' ... 160725 17:00:46 [Note] /usr/libexec/mysqld (mysqld 10.0.26-MariaDB) starting as process 1361 ... 160725 17:00:46 [Note] InnoDB: Using mutexes to ref count buffer pool pages 160725 17:00:46 [Note] InnoDB: The InnoDB memory heap is disabled 160725 17:00:46 [Note] InnoDB: Mutexes and rw_locks use GCC atomic builtins 160725 17:00:46 [Note] InnoDB: Memory barrier is not used 160725 17:00:46 [Note] InnoDB: Compressed tables use zlib 1.2.8 160725 17:00:46 [Note] InnoDB: Using Linux native AIO 160725 17:00:46 [Note] InnoDB: Using CPU crc32 instructions 160725 17:00:46 [Note] InnoDB: Initializing buffer pool, size = 128.0M 160725 17:00:46 [Note] InnoDB: Completed initialization of buffer pool 160725 17:00:46 [Note] InnoDB: Highest supported file format is Barracuda. 160725 17:00:46 [Note] InnoDB: 128 r

  • Issue#1118386: Linux - LXer: MySQL daddy Widenius: Open-source religion won't feed MariaDB

    Published at LXer: Fork off, cash is kingInterview MySQL daddy Monty Widenius has dismissed claims the MariaDB fork is veering away from open source.Â… Read More...

  • Issue#5738: Ubuntu - Linux Mint issue

    How do I use a folder for desktop slide show instead of all pictures?

  • Issue#21471: Linux - MySQL Troubleshooting

    Hi All, I'm a bit new here but for those who are just starting out thought this could be a good resource to check out as it will be recorded and slides will be given at the end of the webinar even if you can not attend. https://www.percona.com/resources/we...ebinars-part-1

  • Issue#25971: Linux - LXer: CenturyLink Adds MySQL-Compatible DBaaS to Managed Cloud Services

    Published at LXer: CenturyLink's new MySQL-compatible DBaaS platform, Relational DB Service, highlights the company's growing investment in managed cloud solutions. Read More...

  • Issue#41673: Linux - systemd dependency issue?

    Hello everyone I am running owncloud on CentOS 7. Everything is working perfectly except one. When I reboot server in owncloud I have error: app":"cron","message":"Failed to connect to the database: An exception occured in driver: SQLSTATE[HY000] [2002] Can't connect to local MySQL server through socket ' In: /usr/lib/systemd/system httpd.service [Unit] Description=The Apache HTTP Server After=network.service mariadb.service remote-fs.target nss-lookup.target mariadb.service [Unit] Description=MariaDB database server After=syslog.target After=network.service I have configured start services in this manner, it solved problem but after several reboot owncloud still logs same error. My question, does that happen because of delay of mysql creates socket after httpd service is starting or it is not related with service dependencies? Thank you

  • Issue#46621: LXer: February 2016 Issue of Linux Journal

    Published at LXer: All of us here in the Linux Journal community have a love for Linux and open source, but even inside our world, there are some topics that are just downright fun! This month is full of articles we're passionate about. Read More...

  • Issue#53224: Linux - Account details issue on kubuntu

    Hello, I am having an issue with account details on Kubuntu on for some reason on "Password and User Account" where you put your name or email from your user, I try to change information and every time I reboot system information goes back to the one before. So, my question is how I can change this, where I have to go or what file I need to edit so the changes I make on email and name are permanent and dont get reset every time I reboot the machine. Thanks.

  • Issue#54933: Linux - Issue with different version of a library (libX11)

    I have a Debian-derived Linux distro with "libX11-6" installed. Every time I try to configure ROOT (a package), then I get the error: "libX11 MUST be installed". I saw the configuration file log and I found this: " [...] libraries to check for: libX11.so libX11.sl libX11.tbd [...]" It tries to find these libraries in some dir, without luck. If I try to install "libX11-dev", it answers with "libX11-dev is already the newest version". The version is the same of libX11-6... I think this problem is due to different filesname of different version of the same library. How can I solve this problem? I am a newbie in linux

  • Issue#59309: DPI issue on linux mint mate

    So I recently did a reinstall of mint (mate) and now my text is small on all 3rd party applications. When I bring up any system text, it's all fine it is only in applications like firefox, or a 3rd party application like osbuddy. I'm wondering if it could be a screen resolution issue, or something along those lines. Any suggestions are appreciated.

  • Issue#59468: Linux - Gnome Screen Lock Issue

    Hi I have Fedora 23 installed on my Asus Laptop. My problem is the following. After the desktop is inactive for 5 minutes, it becomes black (Only the mouse cursor is appearing). Then, if a touch a keyboard button or a mouse, the screen lock appears. I expected that the screen will become black after certain time inactivity. But this is not the case. I looked for similar problems in forums and I did not find somethings relevant. Any Help or suggestion is appreciated. Thaks in advance. By the way, I am using Gnome 3.18.2. I have also KDE Desktop and MATE Desktop installed on my system. Thanks in advance

  • Issue#65266: Lenovo - External Display issue with P50 on Linux

    Hello! I have a P50 (TopSeller 20EN0013US) and dual boot Windows 10 Pro and UbuntuGnome 15.10 with it. I have been having an issue connecting external displays via the laptop's mini-DisplayPort connector. When I plug in an external display while the machine is running, the internal display will begin turning on and off every second, until the external display is disconnected. The external display never turns on. I have the bios set to use dedicated graphics only. I am using the binary Nvidia driver, version 352.63, and have also tried the 352.79, 358.xx, and 361.xx (from the nvidia-drivers ppa) which all have the same issue. I am using the kernel version 4.2.0.27, which is the stock 15.10 ubuntu kernel. The issue does not occur under Windows 10 Pro. I have been able to work around the issue by setting the mini-Displayport to the primary display device (so it is visible at boot, and ends up being used for the console framebuffer), which then allows me to switch to the console

  • Issue#87206: Linux - [SOLVED] Pulseaudio and wine (sound issue) on -current

    I am using mostly playonlinux (so all different versions of wine) however i get this problem with both the wine package from slackbuilds, and within playonlinux, when configuring wine (winecfg) and testing the sound. I can hear no sound in any games, or with the test button; this prints out in the terminal: Code: Aerr:module:load_builtin_dll failed to load .so lib for builtin L"winepulse.drv": libjson-c.so.2: cannot open shared object file: No such file or directory ALSA lib dlmisc.c:254:(snd1_dlobj_cache_get) Cannot open shared library /usr/lib/alsa-lib/libasound_module_pcm_pulse.so ALSA lib dlmisc.c:254:(snd1_dlobj_cache_get) Cannot open shared library /usr/lib/alsa-lib/libasound_module_pcm_pulse.so err:ole:CoInitializeEx Attempt to change threading model of this apartment from multi-threaded to apartment threaded I had recently installed these packages alsa-plugins-compat32-1.1.0-x86_64-2compat32 pulseaudio-compat32-8.0-x86_64-1compat32 , hoping they provide what migh

  • Issue#88213: Linux Mint Cinnamon 17.3 in software rendering mode issue

    This has been chatted about but thought there was no definite resolution. (Is there?) I read this is a bug, is it? Installed Cinnamon 17.3 all the latest ISO/updates etc on an Acer Aspire with an Intel video card. It boots in software rendering, rendering this wee little lappy soggy slow. Here's the output of the famous INXI command: [email protected] ~ $ inxi -F System: Host: aw-AOD270 Kernel: 3.13.0-37-generic i686 (32 bit) Desktop: Cinnamon 2.8.6 Distro: Linux Mint 17.3 Rosa Machine: System: Acer (portable) product: AOD270 v: V1.06 Mobo: Acer model: JE01_CT Bios: Insyde v: V1.06 date: 03/05/2012 CPU: Dual core Intel Atom N2600 (-HT-MCP-) cache: 512 KB clock speeds: max: 1600 MHz 1: 600 MHz 2: 600 MHz 3: 600 MHz 4: 1600 MHz Graphics: Card: Intel Atom Processor D2xxx/N2xxx Integrated Graphics Controller Display Server: X.Org 1.15.1 drivers: (unloaded: fbdev,vesa) Resolution: [email protected] GLX Renderer: Gallium 0.4 on llvmpipe (LLVM 3.4, 128 bits) GLX Version: 2.1 Mesa 10.1.3 Audio: Ca

  • Issue#88422: Linux - LXer: deepSQL Database Promises MySQL Compliance with Cloud Scalability

    Published at LXer: Deep Information Science's deepSQL database leverages machine learning to provide a scalable, efficient MySQL-compliant database for the cloud, the company says. Read More...

  • Issue#90010: Linux - 14.2/Current Xorg issue

    When I try to run Xorg -configure or xorgsetup results in X generating an error and refusing to write an xorg.conf for diagnostic and testing purposes. Xorg is working correcting with the automatic configurations though. I'm on my mobile at the moment, so I can't duplicate or post the error, yet. This is a fresh install for an ISO.

  • Issue#108467: Linux - GT440 + GF210 nvidia driver issue (legacy + regular)

    I run 2 different graphics cards in my host (GT440, GF210) w/ debian testing. Until now, everything worked fine, I could configure them both with the nvidia-settings utility. After the last update, it seems that the GT210 was moved to the legacy driver package (got some warnings and the message I should install this package): Code: Checking card:  NVIDIA Corporation GF108 [GeForce GT 440] (rev a1) Your card is supported by all driver versions. It is recommended to install the     nvidia-driver package. Checking card:  NVIDIA Corporation GT218 [GeForce 210] (rev a2) Your card is only supported up to the 340 legacy drivers series. It is recommended to install the     nvidia-legacy-340xx-driver package. The GF210 does not work any longer. When kernel module of the nvidia-driver package is loaded, it tells me: Code: [  267.550268] NVRM: The NVIDIA GeForce 210 GPU installed in this system is               NVRM:&nb

  • Issue#118499: Linux - systemctl suspend - USB sleep / wake issue

    When I use systemctl suspend one of 3 things happens: 1. Everything suspends fine, and I can wake up my computer by just tapping on the keyboard. 2. The system suspends, but it looks like my keyboard / mouse are still powered on (they remain lit-up). When I go to wake the machine up by tapping on the keyboard nothing happens. I can wake the machine by pressing on the power button, though, and then everything is working fine. 3. Like 2, the system suspends but the keyboard / mouse remain on (or so it looks). I again can't resume with the keyboard. When resuming by pushing the power button the system wakes up, but the keyboard / mouse are unresponsive. Sometimes if I switch the USB port the keyboard / mouse are using they will become active again, while other times I have to restart the machine with the restart button because I can't get the keyboard or mouse to respond. There is no set of conditions that I have identified that leads to 1 vs 2 vs 3. It seems that 2 is the most fr

  • Issue#119782: Linux - unable to update MariaDB from 10.0 to 10.1, error indicating galera libboost dependencies is

    Hello world, I am trying to update my database MariaDB from 10.0 to 10.1 and when I run the yum update command. I am getting this error message below: Any help is appreciated. Resolving Dependencies --> Running transaction check ---> Package galera.x86_64 0:25.3.9-1.rhel7.el7.centos will be updated ---> Package galera.x86_64 0:25.3.12-1.rhel7.el7.centos will be an update --> Processing Dependency: libboost_program_options.so.1.53.0()(64bit) for package: galera-25.3.12-1.rhel7.el7.centos.x86_64 ---> Package google-chrome-stable.x86_64 0:48.0.2564.97-1 will be updated ---> Package google-chrome-stable.x86_64 0:48.0.2564.109-1 will be an update --> Finished Dependency Resolution Error: Package: galera-25.3.12-1.rhel7.el7.centos.x86_64 (mariadb) Requires: libboost_program_options.so.1.53.0()(64bit) You could try using --skip-broken to work around the problem You could try running: rpm -Va --nofiles --nodigest Any suggestions would be helpful. I am stuck at th

  • Issue#120741: Linux - Routing Issue - I think

    I'm having a bit of an issue with a dual network setup in on a VM guest in Proxmox. I'm pretty sure this is not directly Proxmox related. Here is the situation. I have to VM guests, first a pFsense host and second a linux Ubuntu host. The linux Ubuntu host has two network interface cards setup. one with a public IP which currently has all ports blocked with IP tables except port 22 for ssh. The second network interface has a local IP 192.x.x.x The pFsense guest has two network interfaces. The first interface is the WAN interface with a public IP and the second network interface is on the LAN with a local IP of 192.x.x.x Same subnet as the second interface of the Ubuntu guest. I can ping back and forth between the two local IPs of both VMs. I can ssh back and forth between both local interfaces. So all is good there. Both VM guests can also access the internet just fine out of their WAN interfaces. Here is the issue. I would like to port forward say port 2222 from the pFesnse guest

  • Issue#125026: Linux - Slackpkg+ issue on current

    I'm running Slackware64_current as of 11/02/2016 and I'm getting an error when slackpkg+ is enabled via the on/off variable at th etop of slackpkgplus.conf Installed versions are :- Slackpkg-2.82.0-noarch-16 Slackpkg+-1.6.1p2-noarch-1mt when slackpkg+ is enabled I get the following error, ls: cannot access '*.t[blxg]z': No such file or directory Everything seems to work OK ? If it's my setup any hints on where to look for the problem will be gratefully received.

  • Issue#132563: linux ethernet issue

    Hi all I have used UG1165 for "booting linux" http://www.xilinx.com/support/documentation/sw_manuals/xilinx2015_1/ug1165-zynq-embedded-design-tutorial.pdf   It was successfully done until step 14 in page 71 (changing IP addr/subnet mask of host computer) Also, I have connected ethernet cable between host computer and target board(zc706)   After setting IP address for host computer & target board (ZC706),  "ping" command was given on user guide.   So, I basically used ~# ping 192.168.1.1 (for target board ip addr)     Also, I used  ~# ping 192.168.1.5 (for host computer ip addr)   the result is below capture image   using ping command for target board seems working properly while ping command for host computer seems not working.   I assume that both ping command for host computer & target board should work. Am I having a wrong assumption?  If my assumption is correct, how can I fix this issue?   Also I have removed eth

  • Issue#138371: Linux - Multi Interface host resolving issue

    Greetings, I've 2 Wan Interface Eth0 , Eth1 and one out put Lan on eth1. Every thing was working perfect on both wan interfaces , suddenly few days back on eth2 an issue raised that its not resolving any of host indeed ive tried tracert ping nothing worked with domain name but when I ping 8.8.8.8 it does work or dig @8.8.8.8 bing.com it does resolve . I'm using google dns in /etc/resolve.conf nameserver 8.8.8.8 nameserver 4.2.2.2 On other end when I shut down the interface eth2 and up the eth0 it does resolve hostname every thing work like a charm. even I did transfer the eth0 ISP on eth2 it does not work out :/ . I've no local dns running . Im usind dns forwarder only for my local clients using dnsmasq and using google dns for them as well. Any idea what's wrong with that. Regards Net_Spy

  • Issue#140801: Linux - LXer: Top 4 open source issue tracking tools

    Published at LXer: Life is full of bugs.No matter how carefully planned, no matter how much time went into design, any project is*going to have*unforseen issues when the rubber hits the road in the implementation stage. And that's okay. Perhaps the best measure of resiliency for any organization*is not how well they handle things when everything is functioning as planned, but rather, how they handle the speed bumps when they come along.read more Read More...

  • Issue#140893: mysql on linux server

    Hi, I have a mysql database running on linux server, this server is intranet.  I try to connect in Power BI to the server unsuccessfully. When try to connect it shows:Unable to connectWe encountered an erro while tryin to connectDetails: "MySQL:Unable to connect to any of the specified MySQL hosts". I check credentials are fine. Why I entered wasServer: (the intranet IP of ther server)Database: (the name of the db) I choose Database and put the correct credentials. Any help?Please?